Which iPad or iPhone will work with ForeFlight Mobile?

Devices that are compatible with the latest version of ForeFlight Mobile are any iPad or iPhone that can update to iOS 11. Those devices are:

  - iPad Air and newer.

  - iPad Mini 2 and newer.

  - iPhone 5S and newer.

Devices that are not compatible with the latest version of ForeFlight, but can run ForeFlight Mobile 10.6 (an older version) are devices that can run iOS 10.3.3.* Those devices are:

  - iPad 4

  - iPhone 5, 5C

Devices that are not compatible with the latest version of ForeFlight, but can run ForeFlight Mobile 9.6 (an older version) are devices that can run iOS 9.3.5.* Those devices are:

  - iPad 2, 3, 

  - iPad Mini 1

  - iPhone 4S

Devices that are not compatible with any version of ForeFlight Mobile are:

  -iPad 1

  -iPhone 1, 3G, 3GS, 4

The minimum supported version of ForeFlight is version 9.0*.

* To install an older version of the ForeFlight Mobile app, or to reinstall it after deleting from your device, you must have installed ForeFlight Mobile onto a device using your Apple ID. If you have never done so, or do not know the Apple ID used to install the app previously, you will not be able to install ForeFlight unless you have another device with iOS 11 and can use the same Apple ID.

See Also:  I don't see an update for the ForeFlight app in the App Store. What can I do?