What version of ForeFlight will work with my iOS?

Below is a table that shows which iOS version is required for each version of ForeFlight Mobile.

ForeFlight Version Minimum iOS Required Notes
10.2 10.3

Sentry ADS-B In support added 
Some features require iOS 11

10.1 10.3 Some features require iOS 11 
10 10.3 Some features require iOS 11
9.6 9.2  
9.5 9.2  
9.4 9.2  
9.3 9.2  
9.2 9.2 Scout ADS-B In support added
9.1 9.2  
9.0 9.2  
8.3 9.2  
8.2 9.2  
8.1 9.2  
8.0 9.2  
7.7 9.2  
7.6 8.2  
7.5 8.2  
7.4 8.2  
7.3 8.0  
7.2 8.0  
7.1 8.0  
7.0 8.0 Imagery Not Supported
6.8 8.0 Imagery Not Supported
6.7 7.1 Imagery Not Supported 
6.6 7.1 Imagery Not Supported 
6.5 7.1 Imagery Not Supported 
6.4 7.1 Imagery Not Supported 
6.3 7.1 Imagery Not Supported 
6.2 7.1  Imagery Not Supported
6.1 7.1  Imagery Not Supported
6.0 7.1  Imagery Not Supported

NOTE:  The minimum supported version of ForeFlight is version 8.3.

To find the maximum iOS supported by your device, please see List of iOS Devices from Wikipedia.